edited; ps3 controller detected, but buttons not detected

Post Reply

edited; ps3 controller detected, but buttons not detected

Post by dmac »

The controller is a sixaxis dual shock 3. It installed (windows 7); got the message that the usb device was ready for use; xpadder detected it.

However, it won't detect any controller inputs when I set it up. I tried both the playstation 3 controller image file, as well as the sixaxis one, to no avail.

The lights on the controller are blinking, and it is connected using a USB cable. I also tried alternate USB ports.

EDIT: I installed MotionJoy. It works fine (the buttons all respond in windows calibration). Still no luck getting xpadder to work, however.


Primal Fear
Xpadder Xpert
Posts: 2437
Joined: 09 Feb 2010, 16:41
Location: Germany

Re: edited; ps3 controller detected, but buttons not detected

Post by Primal Fear »

By default the DualShock3 doesn't work on a PC without installing Motioninjoy or SCP DS3. It gets detected as a USB-device but not as a controller, so Xpadder isn't detecting it. If Xpadder does detect it, a driver of a third-party PS3 controller is interfering, but still there will be be input.

After installing Motioninjoy you need to start it's DS3 Tool, select the section "Driver Manager", tick your controller in this chart and click on Load driver. If that is done, it should state in the column MotioninJoy "loaded".
Then you select the section Profiles, select either DX-Default or Xinput-Default and click on Enable. You need to do this step every time you connect the controller/restarted your PC to make the analog sticks working and to have a look at the ads (this is why I prefer SCP DS3).

In the end the the controller should be called "MotioninJoy Virtual Controller" (in Xpadder as well as in the Game Controller Control Panel) and LED 1 should be lit up and not all of them blinking.

Post Reply

Return to “Problems detecting controller buttons, triggers or other”