Xpadder not working with Star Conflict

Post Reply
Posts: 1
Joined: 07 Jul 2014, 01:01

Xpadder not working with Star Conflict

Post by stamboulidis »

I've tried running as an admin and it's doing the same thing. It works, but not with the profile that's loaded. It works when I test it in notepad, all the way up until I get into the game itself. I can even see the right stick move inverted just as I have it set up to do so in the menu before the game starts. Any ideas? Thanks.

Primal Fear
Xpadder Xpert
Posts: 2437
Joined: 09 Feb 2010, 16:41
Location: Germany

Re: Xpadder not working with Star Conflict

Post by Primal Fear »

In every way check if Xpadder is really correctly running with admin privileges as explained here (if you didn't do that already).

If it is still not working when Xpadder is running with admin privileges, this is probably because of the Anti-Cheat-Protection of the game. MMO's often tend to disallows emulated keyboard and mouse input as so called farming bots use it too. Unfortunately there is not much you can do except of contacting the developers about your problems, but it's unlikely that they will change anything about that.

Posts: 6
Joined: 18 Aug 2014, 02:03
Location: Ohio for now

Re: Xpadder not working with Star Conflict

Post by ANiMuS »

I thought this happened to me but it was the administrator setting. However, if this does happen it raises questions.

It got me wondering how xpadder passes these commands to the game. I no longer remember my short stint of programming in computer science from back in the 90s so forgive me if my speculations are wrong.

Every time a keyboard button is physically pressed that command is sent to the computer, then the computer passes that command to the program that the user is currently interacting with. Right? So, is xpadder passing its commands directly to the game? :idea: Wouldn't it be better to pass them to the computer and let it pass commands to the game, thereby the game wouldn't know where the computer got these commands? If i'm wrong couldn't some work around be created that essentially does exactly what i'm describing? There has to be a way that the game would have no data prompting it that an emulation is even taking place.

Post Reply

Return to “Xpadder not working in game”